[OVH-WEB] Avertissement sur les anciennes versions PHP

Votre site internet est hébergé chez OVH et vous avez reçu un email vous signalant l'abandon d'anciennes versions de php. Ce message paraît énigmatique pour un non technicien, mais pas de panique, Start Me Up est là pour vous aider.

L'email ressemble à ça:

Bonjour,
Vous avez actuellement un ou plusieurs Hébergement(s) Web qui utilise(nt) le langage PHP pour des pages web.
Dans un souci d'amélioration et de sécurisation des services OVH, nous sensibilisons nos clients sur l'abandon des anciennes versions de PHP, qui ne sont plus maintenues par l'éditeur.
Cela concerne actuellement les versions PHP 4 ainsi que 5.3 et inférieures.
Il est possible que, dans le futur, nous soyons contraints de ne plus supporter ces versions obsolètes. Ainsi, il est recommandé de veiller à la mise à jour régulière de vos pages.
Vous pourrez suivre la planification d'éventuelles actions via la tâche travaux : http://travaux.ovh.net/?do=details&id=12455
Certains de vos sites utilisent une version obsolète de PHP. Nous vous conseillons donc de migrer vers une version plus récente, idéalement PHP 5.5 ou 5.6. Vous trouverez ci-dessous le(s) site(s) concerné(s) :
- [votre-nom-de-domaine] utilise actuellement:
- PHP 5.3
Le support OVH ne pourra pas effectuer les opérations nécessaires sur votre site, du fait du caractère unique de chaque configuration.
Pour vous aider dans la vérification de votre configuration PHP, et sa mise à jour au besoin, un guide est à votre disposition :
https://www.ovh.com/fr/g1207.php-ovh
Par ailleurs, l'utilisation d'une version PHP à jour vous permettra de profiter pleinement des dernières innovations, comme l'optimisation PHP-FPM : https://www.ovh.com/fr/g1175.php-fpm
Merci de votre compréhension.

Vous avez jusqu'au 24 septembre 2015 pour vérifier si votre site est compatible avec php 5.4 ou plus !
Annonce officielle d'OVH
Contactez-nous si vous avez peur de casser quelque chose en faisant la vérification par vous-même ou si vous avez besoin d'un avis pour mettre à jour votre site et le rendre compatible

Explication

PHP est le langage qu'utilisent les serveurs web pour faire tourner des sites internet. C'est le plus répandu (il y en a d'autres moins utilisés) et il arrive maintenant à la version 5.6. Les versions précédentes, php 4 jusqu'à 5.3, sont désormais obsolètes car non mises à jour, ni patchées pour réparer des failles de sécurité, voire incompatibles avec des CMS (Wordpress, Joomla) récents. Du coup OVH a décidé d'abandonner les versions php jusqu'à 5.3 et les serveurs tourneront en 5.4 minimum.

Comment faire, alors ?

Il suffit d'envoyer un petit fichier à la racine de votre espace d'hébergement, et le tour est joué ! Voici la marche à suivre

  1. Connectez-vous à votre espace web OVH via un logiciel FTP comme Filezilla. Vous trouverez les codes de connexion dans un email envoyé par OVH lors de l'achat de votre domaine avec l'hébergement - pour les trouver lancez une recherche du type "[votre-nom-de-domaine] ftp" dans vos emails
  2. Téléchargez ce dossier ovhconfig.zip sur votre ordinateur et décompressez-le. Il contient un fichier .ovhconfig qui fera tourner votre hébergement sous php 5.5
  3. Dans votre logiciel ftp, envoyez ce fichier .ovhconfig à la racine de votre hébergement, au même niveau que les fichiers .bash_logout et .bash_profile
  4. Visitez votre site pour vérifier que tout va bien
  5. C'est tout !

Aïe!! C'est tout cassé, ça marche plus !

Et bien voilà, maintenant vous savez tout, votre site est trop vieux pour supporter des versions plus récentes de php. Si vous constatez des bugs, des affichages bizarres, des comportements inhabituels, c'est le signe qu'il est temps de donner un coup de jeune à votre site internet.

La première chose à faire est de supprimer le fichier .ovhconfig pour revenir à un comportement normal de votre site, mais ce ne sera qu'une solution temporaire jusqu'au 24 septembre 2015, date fatidique où votre site ne s'affichera plus correctement pour personne.

Que faire dans ce cas ?

Vous n'avez pas trop le choix, il faut rendre votre site compatible avec les versions récentes de php, sinon vous partirez dans les oubliettes du web à la 20ème page des résultats de recherche de Google. Et même si vous vous maintenez dans les résultats de recherche pendant un temps, l'expérience des internautes sera tellement perturbée qu'il quitteront rapidement votre site, du coup Google le remarquera (Google sait tout, vous n'y échapperez pas), et vous atterrirez fatalement en 20ème page des résultats de recherche.

Les solutions

Elles dépendent de votre site internet et de la façon dont il a été développé. Bonne nouvelle: beaucoup de sites sont développés à partir de CMS comme Wordpress ou Joomla. Dans ce cas, une mise à jour peut se faire relativement facilement avec une version plus récente de votre theme / template, sans perdre le contenu, mais cela est à étudier au cas par cas. De plus, si votre site n'est pas compatible avec php 5.4, il y a de grandes chances qu'il date d'une époque où le design n'était pas responsive (c'est à dire adapté à tous les écrans), et donc c'est l'occasion de le rendre compatible avec les mobiles, sachant que c'est désormais un critère de positionnement pour Google.

J'ai besoin d'aide ! Help !

Si jamais vous avez la moindre hésitation parce que vous avez peur de faire une fausse manipulation et de tout casser avec le logiciel FTP, si vous n'arrivez pas à vous connecter à votre hébergement chez OVH, si votre site ne fonctionne plus avec le nouveau fichier .ovhconfig, si vous souhaitez savoir comment mettre à jour votre site internet, ou si tout ça c'est du chinois et que vous vous sentez dépassé par la situation ...

Contactez-nous si vous avez besoin d'aide et d'explications pour
vérifier la compatibilité de votre site
étudier la mise à jour de votre site
CONSULTATION GRATUITE SANS ENGAGEMENT

Conclusion

Cette décision d'OVH n'a rien d'étonnant, ils sont juste un peu en avance par rapport aux autres hébergeurs. Le web évolue mécaniquement et impose ses contraintes elles-mêmes dictées par les évolutions technologiques et les modes de navigation des internautes. En fait, cette mise à jour importante est une occasion salutaire de faire le point sur votre site et de le rendre plus agréable à naviguer pour les internautes.

C'est bien ce qui compte, non ?

Contactez-nous

Envoyez-nous un message pour prendre un premier rendez-vous et analyser vos besoins. C'est gratuit, et on boit un petit café ;)

Soyons connectés